Platform Status

Web Wallet Offline
Incident Report for Block.io, Inc.
Resolved
Infrastructure instability for Web Wallet caused the issue. This is now resolved.
Posted Apr 09, 2020 - 20:45 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2020 - 14:26 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 09, 2020 - 14:17 PDT
This incident affected: Web Wallet.