Inbound DDoS
Incident Report for Block.io, Inc.
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 20, 2017 - 15:47 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Feb 17, 2017 - 16:28 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Feb 16, 2017 - 02:12 PST