Datacenter Outage
Incident Report for Block.io, Inc.
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 10, 2017 - 20:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Oct 10, 2017 - 19:50 PDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Oct 10, 2017 - 19:43 PDT